Connectivity isues
Incident Report for Coinfloor
Resolved
This incident has been resolved.
Posted over 2 years ago. Mar 26, 2015 - 14:12 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted over 2 years ago. Mar 26, 2015 - 08:40 UTC
Investigating
Website may be unavailable for some users.
Posted over 2 years ago. Mar 26, 2015 - 00:14 UTC